Package conflict question

asked 2017-03-13 21:44:48 -0800

kang gravatar image

updated 2017-03-13 21:45:36 -0800

I had get a package conflict issue when install a bundle about 'sal' package.

Error log is,

Error executing command: Error executing command on bundles: Unable to execute command on bundle 65: The bundle "org.opendaylight.odlparent.helloworld_1.8.0.SNAPSHOT [65]" could not be resolved. Reason: Package uses conflict: Import-Package: org.opendaylight.controller.sal.core; version="[0.7.0,1.0.0)"

My pom.xml

<parent> <groupid>org.opendaylight.odlparent</groupid> <artifactid>odlparent</artifactid> <version>1.8.0-SNAPSHOT</version> <relativepath/> </parent>

    <dependency>
        <groupId>org.opendaylight.controller</groupId>
        <artifactId>sal</artifactId>
        <version>0.7.0</version>
    </dependency>

. . .

please help me.

edit retag flag offensive close merge delete