Ask Your Question
0

iotdm: no response from restconf when trying to create CSE

asked 2017-02-10 02:38:19 -0700

DaEwe gravatar image

updated 2017-02-10 04:52:58 -0700

Hi, I am trying to setup onem2m as described here: https://wiki.opendaylight.org/view/Io...

I can verify that all neccessary features are running (see below). However, I can't setup the CSE. My request

curl -v -X POST -H "Content-Type: application/json" -H "Accept: application/json" -H "Authorization: Basic YWRtaW46YWRtaW4=" -d '{ "input": {"onem2m-primitive": 
    [
        {"name": "CSE_ID",
         "value": "InCSE1"},
        {"name": "CSE_TYPE",
         "value": "IN-CSE"}
    ]
 }}' localhost:8181/restconf/operations/onem2m:onem2m-cse-provisioning

hangs without response.

Subsequent calls to query the CSE fail with `{"error":"Resource target URI not found: /InCSE1"}

Listing of services:

opendaylight-user@root>list|grep restconf
100 | Active      |  80 | 2013.10.19.8_4-Beryllium-SR4       | ietf-restconf
opendaylight-user@root>list|grep onem2m
259 | Active      |  80 | 0.1.4.Beryllium-SR4                | onem2m-api
260 | Active      |  80 | 0.1.4.Beryllium-SR4                | onem2m-core
262 | Active      |  80 | 0.1.4.Beryllium-SR4                | onem2m-notifier
264 | Active      |  80 | 0.1.4.Beryllium-SR4                | onem2m-protocol-coap
265 | Active      |  80 | 0.1.4.Beryllium-SR4                | onem2m-protocol-http
267 | Active      |  80 | 0.1.4.Beryllium-SR4                | onem2m-protocol-mqtt

I get the same issue with both the official Beryllium SR4 and the provided snapshot download

How can I find out what's wrong? Any hints?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-02-10 12:35:03 -0700

DaEwe gravatar image

Solved it:

I had another instance of jetty running on the same server, listening on port 8080. Karaf couldn't bind to that port (and complained about it silently in karaf.log). Stopping the external jetty solved the issue.

edit flag offensive delete publish link more
0

answered 2017-02-15 08:09:09 -0700

I have the same problem. I'm a bit confused why your jetty instance on port 8080 interferes with the restconf service on 8181.

I've nothing else on 8181 (or 8080) but I still get a timeout.

edit flag offensive delete publish link more

Comments

Update: I too have solved it but not sure why. I did actually have something running on 8080 (it was Tomcat which was shown when I added sudo to the front of my lsof -i 8080 command). When I stopped tomcat and restarted karaf, the restconf service started working. Not sure why restconf needs 8080.

Alistair Duke ( 2017-02-15 08:51:09 -0700 )edit

Take a look at data/log/karaf.log In my case it listed a Java exception about not being able to bind to 8080.

DaEwe ( 2017-02-16 22:46:19 -0700 )edit
Login/Signup to Answer

Stats

Asked: 2017-02-10 02:38:19 -0700

Seen: 35 times

Last updated: Feb 15