6633 port is bind to tcp6, so Mininet is not able to connect to the SDN (Boron) Controller

asked 2017-01-31 06:12:04 -0700

dev.dillip gravatar image

updated 2017-02-01 06:44:37 -0700

In short problem is, controller is starting and it's getting bind to the port 6633 but with tcp6 which should be with tcp.

Detailed : I have installed Virtual Box on Windows 10. Ubuntu 14.04 is my current guest machine. Below are the steps i am following to run the Boron SDN controller.

  1. Download the Boron (distribution-karaf-0.5.2-Boron-SR2/0.5.1-SR1)

  2. Install the features feature:install odl-dlux-all feature:install odl-restconf-all feature:install odl-l2switch-all

  3. Once the "odl-l2switch-all" gets installed i could see the below output from "netstat -atpne"

tcp6 0 0 :::6653 :::* LISTEN 0 19439 - tcp6 0 0 :::6633 :::* LISTEN 0 19438 -

As the ports 6633 and 6653 are bound to tcp6 i am unable to connect to the Controller from my mininet which is running in an another instance.

I am able to ping to the controller vm from the mininet vm but not able to connect(mn --topo=single,2 --controller=remote,ip=:6633) as i am trying over ipv4/tcp.

My requirement is to connect over v4. To achieve the same I had disabled the v6 in controller vm by configuring the sysctl.conf, also had disable IPv6 in host machine(W10/regedit), but once i install the odl-l2switch, these 2 ports are getting bind to tcp6.

I tried the same with VMWare but the behavior is the same. Please suggest how to resolve this and is it a know issue ?

edit retag flag offensive close merge delete