Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

Unable to see flows which I added via postman or Yangui ?

asked 2016-11-16 00:26:01 -0800

Omkar Deshpande gravatar image

Hello, I am trying to implement a simple topology with mininet and opendaylight. I am adding flows using rest api via Postman. I get status 200 ok but I cannot verify the same when I try to look into ovs-ofctl dump-flows <bridge>. I also checked the log:display in karaf, it shows that there is some entry added to the switch. But it doesn't show in ovs. Thank you

Regards, Omkar

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-11-17 09:13:04 -0800

ahuja gravatar image

Try this command: ovs-ofctl -O OpenFlow13 dump-flows <bridge>

edit flag offensive delete publish link more

Comments

Hello, I have tried this but still it doesn't work . I also followed the suggestions from RESTCONF troubleshooting thread, it didn't work. So i'm trying to figure it out.

Omkar Deshpande ( 2016-11-21 23:38:36 -0800 )edit

Hello Omkar, Check the wireshark capture on mininet. See if the flows you are adding are really being received by the switch. Also, post here how you are adding the flow.

ahuja ( 2016-11-22 07:08:54 -0800 )edit
0

answered 2016-11-22 07:33:40 -0800

Omkar Deshpande gravatar image

updated 2016-11-22 07:38:13 -0800

Hello Ahuja I am trying to find out how can i capture packets since my Opendaylight controller and Mininet VM are on remote server. However I tried other way, I added the flow in OVS and checked the status in controller operational datastore. It does show but the flow id is something like like "#UF$TABLE*0-16". I'm still working on it. Here is the flow: http://localhost:8181/restconf/config...

<flow xmlns="urn:opendaylight:flow:inventory"> <instructions> <instruction> <order>0</order> <apply-actions> <action> <order>0</order> <drop-action/> </action> </apply-actions> </instruction> </instructions> <table_id>0</table_id> <id>1</id> <match> <ethernet-match> <ethernet-type> <type>2048</type> </ethernet-type> </ethernet-match> <ip-match> <ip-protocol>6</ip-protocol> </ip-match> <ipv4-source>10.0.0.1/8</ipv4-source> <ipv4-destination>10.0.0.3/8</ipv4-destination> </match> <hard-timeout>0</hard-timeout> <cookie>10</cookie> <idle-timeout>0</idle-timeout> <flow-name>f1</flow-name> <priority>200</priority> </flow>

edit flag offensive delete publish link more

Comments

There are some mistakes in the flow for sure. Let me check.

ahuja ( 2016-11-22 08:47:46 -0800 )edit

remove <ipv4-source>10.0.0.1/8</ipv4-source> <ipv4-destination>10.0.0.3/8</ipv4-destination> and you will notice that it starts working. So there is some issue with this part of the code which you need to fix it. I will also try to do this.

ahuja ( 2016-11-22 09:00:20 -0800 )edit

Yeah true my mistake! Thanks ahuja. I should have written 10.0.0.0/8 or 10.0.0.3/32.

Omkar Deshpande ( 2016-11-22 23:39:41 -0800 )edit

Thats right... you should mark the entire subnet,

ahuja ( 2016-11-27 13:29:12 -0800 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2016-11-16 00:26:01 -0800

Seen: 65 times

Last updated: Nov 22 '16