Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

Training at summit 2016

asked 2016-11-08 02:20:00 -0800

wwzoon gravatar image

Hello everyone, i try to watch and do this training. I downloaded the VM, but if i create a mvn template with archetype it doesn't compile well. The slides are so poor of technical information and dosent going to deep. In the video, i think, explain more but its hard to follow if i can't read what the programmer is typing. Someone have the same problem? I really like the Yang example and the trasformation of this in java code, but i really need more information about why i can't create a archetype and the structure after the compile the yang file. Some really well guide of yang to java code already exists? Thank you for every answer

edit retag flag offensive close merge delete

Comments

What training are you talking about? The NETCONF/YANG, the BGP/PCEP, the Application development,...?

adetalhouet ( 2016-11-08 09:12:39 -0800 )edit

Writing an application, sorry i missed the most important information. Btw everytime that i try to build, sample template or the example that they give you, everytime dosent build and the result is an error

wwzoon ( 2016-11-09 01:08:14 -0800 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-11-09 11:00:27 -0800

updated 2016-11-09 11:01:24 -0800

Hello,

That wiki has a presentation of the OpenDaylight archetype to create an application from scratch. It will also guide you through some basic functionality, such as defining and implementing an RPC. The archetype works well with the mentioned version. That wiki is 75% up-to-date and everything works, the 25% missing is missing information.

Hope this helps, Alexis

edit flag offensive delete publish link more
0

answered 2016-11-10 01:05:47 -0800

wwzoon gravatar image

Thank you, but i finally find the error. In the VM that they give for the training the file pom.xml in the first exercize is wrong:

<dependency>
       <groupId>org.opendaylight.mdsal.model</groupId>
       <artifactId>ietf-packet-fields</artifactId>
       <version>0.7.0-SNAPSHOT</version>      //****HERE IS THE ERROR
</dependency>

* 0.7.0 is not exists or is updated to 0.7.1 or 0.7.2 so it cant compile without this fix. Maybe for all is easy, but for me was a problem. I hope that someone fix it

edit flag offensive delete publish link more

Comments

i had the same issue, and i changed 0.7.0 to 0.8.0, and it worked. can you explain how did you find out the issue ? thanks.

aseaudi ( 2017-07-08 04:09:06 -0800 )edit
Login/Signup to Answer

Stats

Asked: 2016-11-08 02:20:00 -0800

Seen: 38 times

Last updated: Nov 10 '16