Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode


L2 switch in Boron

asked 2016-10-12 07:37:32 -0700

SlOPS gravatar image

updated 2016-10-12 23:10:30 -0700

I've installed Boron version with feature:install odl-restconf odl-l2switch-switch odl-dlux-all openjdk-8-jre-headless and connected openvswitch 2.5.0 to it. I see switch at Dlux but no network activity happens. The rules are:

cookie=0x2b00000000000000, duration=59.952s, table=0, npackets=0, nbytes=0, idleage=59, priority=100,dltype=0x88cc actions=CONTROLLER:65535 cookie=0x2b00000000000000, duration=59.952s, table=0, npackets=66, nbytes=4116, idle_age=0, priority=0 actions=drop

All VM's packets goes to drop

edit retag flag offensive close merge delete


I have no problems with Beryllium-SR3

SlOPS ( 2016-10-17 04:24:01 -0700 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2016-10-13 14:02:12 -0700

updated 2016-10-17 18:16:17 -0700


I'm not sure what is the question here. I mean "no network activity happens" but are you expecting any? Is your openvswitch instance has bridges, ports, hosts, ...? Are they any links?

Thanks, Alexis

----- Edit

I actually tried to load those features in Official Boron distribution, there is indeed a BUG. I opened this ticket if you want to track this.

edit flag offensive delete publish link more


I have no any problem with Beryllium-SR3. OVS has 2 ports connected to namespaces.

SlOPS ( 2016-10-17 04:25:51 -0700 )edit

Correct, it is broken in Boron, see edited answer above. Thanks for reporting.

adetalhouet ( 2016-10-17 18:11:03 -0700 )edit

As a workaround, using odl-l2switch-switch-ui should work fine

adetalhouet ( 2016-10-18 05:38:09 -0700 )edit

answered 2016-10-17 01:00:51 -0700

Mandeep gravatar image

You have installed odl-l2switch-switch (I would suggest to install odl-l2switch-all), which should add default flows in all switches. So hopefully your switches are reachable to each other. Or you can try Add default flow to allow all

If you are using Mininet (for network creation & topology), then try (from Mininet console) to check all switches are reachable to each other or not.


If reachable, but still not able to see packets, then you can try basic TCP connecion using nc to test connectivity.

start two host terminals (from mininet console):

xterm h1 h2

h1 host: (tcp server)

$ nc -l 9000

h2 host: (tcp client, type your message. It should appear in the h1 host terminal)

$ nc 9000
edit flag offensive delete publish link more
Login/Signup to Answer


Asked: 2016-10-12 07:37:32 -0700

Seen: 282 times

Last updated: Oct 17 '16