Ask Your Question
0

When installed newest Helium, http://localhost:8080 doesn't work

asked 2014-12-01 03:55:40 -0700

gedyz gravatar image

updated 2014-12-01 04:00:54 -0700

Hello, sorry for maybe lame question, but this problem is annoying me and my college for more than a week. I did everything mentioned in Developers Guide when installing Helium-SR1, and after running ./target/assembly/bin/karaf, controller have started, but http://localhost:8080 says Unable to connect. Maybe somebody also faced this problem? I'm using VM with Ubuntu 12.04

edit retag flag offensive close merge delete

Comments

Can you post which Developers Guide are you referring to, so that the developers can fix it?

Dana ( 2014-12-01 05:26:05 -0700 )edit

https://www.opendaylight.org/sites/opendaylight/files/bk-developers-guide-20141002.pdf

gedyz ( 2014-12-01 05:29:59 -0700 )edit

Please try installing restconf feature. In karaf prompt: feature:install odl-restconf-noauth

Dana ( 2014-12-01 06:00:42 -0700 )edit

I tried, bus still not working. Which address should be usable after that? localhost:8080?

gedyz ( 2014-12-01 12:55:12 -0700 )edit

One thing I haven't done is setting git review

gedyz ( 2014-12-01 12:56:19 -0700 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-12-01 05:25:29 -0700

Dana gravatar image

updated 2014-12-01 06:05:31 -0700

The default port in Helium is 8181.

EDIT: also RESTCONF feature needs to be installed. In Karaf prompt:

feature:install odl-restconf-noauth

edit flag offensive delete publish link more

Comments

I also tried 8181, doesn't work either

gedyz ( 2014-12-01 05:29:44 -0700 )edit

Which features did you install?

Chris O'Shea ( 2014-12-01 08:47:49 -0700 )edit

None, there wasn't mentioned any to install

gedyz ( 2014-12-01 12:53:24 -0700 )edit

I recommend running this command are the karaf prompt (opendaylight-user@root>) ' feature:install odl-restconf odl-l2switch-switch odl-mdsal-apidocs odl-dlux-core'

Chris O'Shea ( 2014-12-01 12:58:48 -0700 )edit

Error executing command: No feature named 'odl-l2switch-switch' with version '0.0.0' available

gedyz ( 2014-12-01 13:00:59 -0700 )edit
2

answered 2014-12-03 17:00:21 -0700

chilwan gravatar image

I had the same problem when I pulled using GitHub. The reason is that once you pull it and build it, it only pulls the features required for controller, in order to get DLUX (the web interface feature) you need to pull that feature as well and so on.

Instead, I suggest (and I also did the same) that you download the TAR/ZIP file from ODL website, Unzip/Untar it and then run karaf from its bin folder. Now you can use the following command to install the DLUX feature:

feature:install odl-dlux-core

edit flag offensive delete publish link more

Comments

thanks, I have done the same, except odl-dlux-core, I installed l2switch which instaled dlux automaticaly :)

gedyz ( 2014-12-04 02:16:57 -0700 )edit
0

answered 2014-12-01 05:46:28 -0700

mnanduri gravatar image

updated 2014-12-01 05:56:00 -0700

Works for me, just installed it and tried.

edit flag offensive delete publish link more

Comments

Good for You :)

gedyz ( 2014-12-01 12:55:37 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2014-12-01 03:55:40 -0700

Seen: 1,128 times

Last updated: Dec 03 '14