Blocking ARP Traffic with 54-arphandler.xml doesn't work

asked 2016-09-08 05:35:29 -0800

Networker gravatar image

updated 2016-09-08 05:43:59 -0800

Hi at all,

I have a question concerning setting flow rules for ARP traffic in the network. I am working with OpenDaylight Beryllium SR3 and Mininet. The is-proactive-flood-mode is set to false. The id-hybrid-mode is set to false. I would like to have a network where no traffic exept LLDP passes through until I set the flow rules for it.

When building a network with these parameters the following flow rules are automatically set in the switches:

cookie=XYZ, duration=XYZ, table=0, npackets=XYZ, nbytes=XYZ, priority=100,dl_type=0x88cc actions=CONTROLLER:65535

cookie=XYZ, duration=XYZ, table=0, npackets=XYZ, nbytes=XYZ, priority=1,arp actions=CONTROLLER:65535

cookie=XYZ, duration=XYZ, table=0, npackets=XYZ, nbytes=XYZ, priority=0 actions=drop

The first flow is forwarding of LLDP packets to the controller, thats good. But the second is making problems I think. On first pingall command in the mininet CLI I get no anwers, so far so good. But on the second and third try the switches answer to pings as normal.

For each and every MAC source and MAC destination a flow rule is automatically set in every switch with a hard-timeout of 600ms.

Where does that come from and how can I stop this behaviour of the controller automatically setting flow rules in the switches?

Thanks in advance for any helpful answers. A colleaque of mine is working with the Brocade ODL controller and it seems to work with him.

edit retag flag offensive close merge delete