Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode


make is-proactive-flood-mode to false in l2switch

asked 2016-07-26 11:33:14 -0700

sandaruny gravatar image

updated 2016-07-26 11:33:34 -0700

Hi there, I wonder there is a way to set is-proactive-flood-mode to false in opendaylight version 4.0 snapshots. I used the 54-arphandler.xml in the /etc/opendaylight/karaf directory and when I restarted controller, its still shows

ArpHandler is in Proactive Flood Mode

Is there any way to change this? Even with yang models?

edit retag flag offensive close merge delete


Make sure that in controller also having the same version of l2switch(4.0) . built it and try again

karthik330 ( 2016-07-27 06:52:30 -0700 )edit

I tried that. But it was not working. I hacked the yang config file in arphandler package by making default: false. Then it worked. But I will try more to get familiar with it. Thanks.

sandaruny ( 2016-07-27 08:07:13 -0700 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-07-27 15:06:53 -0700

saisujithreddy gravatar image

updated 2016-08-08 15:03:06 -0700

After Blueprint patches got merged, it should be still possible to change values from an external file - Please find more information here [0] on how to use it. Full details on Blue Print are here [1]

[0] link:[] [1] link:[]

edit flag offensive delete publish link more


Hey I think the link is not working. Could you please be kind enough to re check it?

sandaruny ( 2016-07-29 07:18:44 -0700 )edit

Done. Seems there was a change in the name of the article hence the link was broken. Updated it.

saisujithreddy ( 2016-08-08 13:23:59 -0700 )edit

[0] link:[] [1] link:[] Seems the underscore character is getting truncated in the answer section.

saisujithreddy ( 2016-08-08 16:06:47 -0700 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2016-07-26 11:33:14 -0700

Seen: 122 times

Last updated: Aug 08 '16