Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

http://127.0.0.1:8080/ is not showing OpenDayLight GUI?

asked 2014-05-07 10:23:27 -0700

updated 2014-05-07 10:25:25 -0700

I successfully build and OSGI is running successfully. But the thing more troubling me is when I run :

http://127.0.0.1:8080/

on my web browser it shows

{"code":404,"description":"The server has not found anything matching the request URI","reasonPhrase":"Not Found","throwable":null,"uri":"http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html#sec10.4.5","globalError":false,"redirection":false,"recoverableError":false,"error":true, "success":false,"informational":false,"serverError":false,"connectorError":false,"clientError":true}

As shown here: ScreenShot

I wonder what might be the problem? Even I tried

http://localhost:8080/

It shows the same error text.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-05-07 16:22:56 -0700

Colin Dixon gravatar image

updated 2014-05-07 16:24:27 -0700

Could you provide a bit more context? Did you wait for about 20-30 seconds after loading the controller? In my experience the behavior is somewhat odd until then.

Also, if you're still running into problems, can you let us know what OS and version you're running? What version of the code you're using? and what java and maven versions you're using? That is the output of "java -version", "mvn -v", "git log -1 --pretty=oneline", and "git status -s".

edit flag offensive delete publish link more

Comments

I guess the problem is due to Running 2 different controller. In my case I have running: 1. Floodlight using Eclipse and 2.OpenDayLight using CLI Anyways, this problem can trouble some but simple solution is to close one controller and run the browser. Now My problem is gone! Thanks @Colin

milstein ( 2014-05-07 17:53:09 -0700 )edit

Or you could change the GUI listening port in one of the controllers, allowing you to keep them running at the same time. For ODL, you need to edit the configuration/tomcat-server.xml file.

lori ( 2014-05-14 06:50:16 -0700 )edit

Thanks @lori I will try that.

milstein ( 2014-05-14 07:57:00 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2014-05-07 10:23:27 -0700

Seen: 11,008 times

Last updated: May 07 '14