Ask Your Question
0

Error in resolving new dependencies in NETCONF

asked 2016-06-02 02:35:10 -0700

KushalKumar gravatar image

Hi All,

I have implemented a new functionality in NETCONF plugin of opendaylight. For this, I required certain addditional dependencies that I have added in the pom for netconf-impl (module inside netconf plugin code where I am implementing the functionality). These dependencies were available in nexus.opendaylight.org .

Now after adding those dependencies in pom and making changes to features.xml for netconf plugin. I get the below error after starting feature odl-netconf-connector-all.

opendaylight-user@root>feature:install odl-netconf-connector-all odl-restconf-all Error executing command: Can't install feature odl-netconf-connector-all/0.0.0:
Could not start bundle mvn:org.opendaylight.controller/netconf-impl/0.3.0-Lithium in feature(s) odl-netconf-impl-0.3.0-Lithium: The bundle "org.opendaylight.controller.netconf-impl_0.3.0.Lithium [216]" could not be resolved. Reason: Missing Constraint: Import-Package: org.kie.api; version="[6.2.0,7.0.0)"

Please let me know if any other details are required. I am stuck with this dependency resolution problem since a long time.

Would be great if somebody has some insight into this issue and can help.

My features.xml section for odl-netconf-connector-all :

<feature name='odl-netconf-connector-all' version='${project.version}' description='OpenDaylight :: Netconf Connector :: All'>
    <!--
        Necessary TODO:
        List all of the user consumable features you define in this feature file here.
        Generally you would *not* list individual bundles here, but only features defined in *this* file.
        It is useful to list them in the same order they occur in the file.

        Examples:
        <feature version='${project.version}'>odl-controller-provider</feature>
        <feature version='${project.version}'>odl-controller-model</feature>
    -->
    <feature version='${project.version}'>odl-netconf-connector</feature>
    <feature version='${project.version}'>odl-netconf-connector-ssh</feature>
    <bundle>wrap:mvn:com.google.guava/guava/${guava.version}</bundle>
    <bundle>wrap:mvn:org.kie/kie-api/6.2.0.Final</bundle>
    <bundle>wrap:mvn:org.drools/drools-core/6.2.0.Final</bundle>
    <bundle>wrap:mvn:org.drools/drools-compiler/6.2.0.Final</bundle>
    <bundle>wrap:mvn:org.drools/drools-decisiontables/6.2.0.Final</bundle>
    <bundle>wrap:mvn:org.drools/drools-osgi-integration/6.2.0.Final</bundle>
    <bundle>wrap:mvn:org.drools/knowledge-api/6.2.0.Final</bundle>
</feature>

My POM :

http://maven.apache.org/xsd/maven-4.0...> 4.0.0

<parent> <groupid>org.opendaylight.controller</groupid> <artifactid>netconf-subsystem</artifactid> <version>0.3.0-Lithium</version> </parent> <artifactid>netconf-impl</artifactid> <packaging>bundle</packaging> <name>${project.artifactId}</name>

<properties>
    <drools.version>6.2.0.Final</drools.version>
    <json.version>1.1.1</json.version>
    <guava.version>18.0</guava.version>

</properties>

<dependencies>
  <dependency>
      <groupId>org.drools</groupId>
      <artifactId>knowledge-api</artifactId>
      <version>${drools.version}</version>
  </dependency>
  <dependency>
      <groupId>org.kie</groupId>
      <artifactId>kie-api</artifactId>
      <version>${drools.version}</version>
  </dependency>
  <dependency>
      <groupId>org.drools</groupId>
      <artifactId>drools-core</artifactId>
      <version>${drools.version}</version>
  </dependency>
  <dependency>
      <groupId>org.drools</groupId>
      <artifactId>drools-compiler</artifactId>
      <version>${drools.version}</version>
  </dependency>
  <dependency>
      <groupId>org.drools</groupId>
      <artifactId>drools-decisiontables</artifactId>
      <version>${drools.version}</version>
  </dependency>
  <dependency>
      <groupId>org.osgi</groupId>
      <artifactId>org.osgi.core</artifactId>
  </dependency>
  <dependency>
      <groupId>org.drools</groupId>
      <artifactId>drools-osgi-integration</artifactId>
      <version>${drools.version}</version>
  </dependency>
  <dependency>
      <groupId>com.googlecode.json-simple</groupId>
      <artifactId>json-simple</artifactId>
      <version>${json.version}</version ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-06-02 03:22:39 -0700

jgoodyear gravatar image

Try installing wrap:mvn:org.kie/kie-api/6.2.0.Final manually in ODL.

Can you start that bundle? If so, check to see what packages its exporting & version. If not, than resolve this bundles issues.

Now try installing manually the bundles from your feature file. Continue this process until all bundles are installed, resolved, and started.

Please post back how far you get in this process.

edit flag offensive delete publish link more
0

answered 2016-06-06 23:06:14 -0700

KushalKumar gravatar image

I tried installing and starting the kie-api bundle in OSGI but it failed. Also, I cannot start the bundle "netconf-impl". bundle:install file:///home/directv/Downloads/kie-api-6.2.0.Final.jar Bundle ID: 453 opendaylight-user@root>start 453 Error executing command: Error executing command on bundles: Unable to execute command on bundle 453: The bundle "org.kie.api_6.2.0.201503042108 [453]" could not be resolved. Reason: Missing Constraint: Import-Package: org.drools.compiler.kie.builder.impl; version="0.0.0" opendaylight-user@root>

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2016-06-02 02:35:10 -0700

Seen: 149 times

Last updated: Jun 06 '16