Ask Your Question
0

Error reaching port 29418 of git.opendaylight.org

asked 2016-05-26 13:43:06 -0700

medha_j gravatar image

myjoshi@sdnvm:~$ ssh -p 29418 git.opendaylight.org ssh: connect to host git.opendaylight.org port 29418: Network is unreachable

I could ping git.opendaylight.org though. Is is corporate firewall problem ? How to get around it ? Thanks,

Medha

myjoshi@sdnvm:~$ ping git.opendaylight.org PING dev.opendaylight.org (72.3.167.142) 56(84) bytes of data. 64 bytes from 72.3.167.142: icmp seq=1 ttl=231 time=95.8 ms 64 bytes from 72.3.167.142: icmpseq=2 ttl=231 time=95.9 ms 64 bytes from 72.3.167.142: icmpseq=3 ttl=231 time=96.1 ms 64 bytes from 72.3.167.142: icmpseq=4 ttl=231 time=96.4 ms 64 bytes from 72.3.167.142: icmpseq=5 ttl=231 time=96.2 ms 64 bytes from 72.3.167.142: icmpseq=6 ttl=231 time=95.3 ms 64 bytes from 72.3.167.142: icmpseq=7 ttl=231 time=96.1 ms 64 bytes from 72.3.167.142: icmpseq=8 ttl=231 time=96.3 ms 64 bytes from 72.3.167.142: icmpseq=9 ttl=231 time=96.4 ms 64 bytes from 72.3.167.142: icmp seq=10 ttl=231 time=95.9 ms 64 bytes from 72.3.167.142: icmp_seq=11 ttl=231 time=96.3 ms ^C --- dev.opendaylight.org ping statistics --- 11 packets transmitted, 11 received, 0% packet loss, time 10014ms rtt min/avg/max/mdev = 95.381/96.114/96.443/0.462 ms

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2016-05-27 07:43:18 -0700

Linux Foundation Staff

Was this yesterday inside 19:24 - 21:20 PDT? If so there was an issue with our datacenter provider that was causing a lot of network instability.

If it wasn't during that window and is a persistent problem, then yes, it's likely a corporate firewall. To get around it you will likely need to use https to access Gerrit instead of SSH.

See our setting up HTTPS access in Gerrit guide.

edit flag offensive delete publish link more
0

answered 2016-05-31 09:03:59 -0700

medha_j gravatar image

Thanks for replying. I think, it was outside the time window you mentioned. Thanks for a link to workaround corporate firewall.

I am having another problem and I am not behind the corporate firewall.

myjoshi@sdnvm:~$ ssh -p 29418 myjoshi@git.opendaylight.org The authenticity of host '[git.opendaylight.org]:29418 ([72.3.167.142]:29418)' can't be established. RSA key fingerprint is 5f:92:db:a0:0f:31:ff:33:6b:d3:ae:a1:b0:d6:b8:eb. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added '[git.opendaylight.org]:29418,[72.3.167.142]:29418' (RSA) to the list of known hosts. Permission denied (publickey). myjoshi@sdnvm:~$ ssh -p 29418 myjoshi@git.opendaylight.org Permission denied (publickey).

What is resolution for this problem ? I am confused as we set public key on ssh on the account.

Thanks,

Medha

edit flag offensive delete publish link more

Comments

Do you have the private key portion on your local system that you used? Gerrit's SSH system, while it isn't the system level SSH daemon, works just the same as any other SSH daemon. If you don't have the private key to match a public key, you won't be able to connect.

agrimberg ( 2016-05-31 09:24:42 -0700 )edit

yes, I have. Thanks for help.

medha_j ( 2016-06-02 10:50:30 -0700 )edit

I just reread what you're trying to do. Gerrit won't allow you to actually do an interactive connection on port 29418. There's no shell access. At best you can do something like 'ssh -p 29418 myjoshi@git.opendaylight.org gerrit help' to see what commands you can execute

agrimberg ( 2016-06-02 11:23:41 -0700 )edit

Thanks for the help. My problem is solved.

medha_j ( 2016-06-04 21:41:14 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2016-05-26 13:43:06 -0700

Seen: 153 times

Last updated: May 31 '16