Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

br-tun and br-int is not connected in ODL controller. Anybody know the reason why?

asked 2014-11-17 11:12:51 -0800

madhu22 gravatar image

Br-tun and br-int is showing up in the ODL controller, but is not connected. Below are the commands from the openstack controller

[root@rdo-openstack-compute ~]# ovs-ofctl -O OpenFlow13 dump-flows br-int OFPSTFLOW reply (OF1.3) (xid=0x2): cookie=0x0, duration=1480.679s, table=0, npackets=292, nbytes=26572, sendflowrem dltype=0x88cc actions=CONTROLLER:56

[root@rdo-openstack-compute ~]# ovs-vsctl show f0098f1f-5118-4f16-8040-4681c504252c Manager "tcp:10.x.y.y:6640" isconnected: true Bridge br-tun Controller "tcp:10.x.y.y:6633" isconnected: true Port "vxlan-0a0b60ef" Interface "vxlan-0a0b60ef" type: vxlan options: {dfdefault="true", inkey=flow, localip="10.x.x.x", outkey=flow, remoteip="10.y.y.y"} Port patch-int Interface patch-int type: patch options: {peer=patch-tun} Port br-tun Interface br-tun type: internal Bridge br-int Controller "tcp:10.x.y.y:6633" isconnected: true failmode: secure Port br-int Interface br-int type: internal Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} ovsversion: "2.3.0"

ODL controller

Nodes connected to this controller : [MDSAL|openflow:11967843298379, MDSAL|openflow:2342329537867, OVS|10.x.x.x:39005, MDSAL|openflow:191472679423044, MDSAL|openflow:182865673765959, MD_SAL|openflow:29530181377103]

I have also pasted the commands in this link: http://pastebin.com/2iQmfQ72

edit retag flag offensive close merge delete

Comments

do you mean, switches are present in the topology, but there is not link between them? Can you please paste the ovs-ofctl output on both br-tun and br-int. Also can you please run wireshark on the compute node and see if br-tun bridge is receiving the LLDP packets and also its sending it back to controller or not.

Anil Vishnoi ( 2014-11-19 03:31:39 -0800 )edit

@Anil--Thanks for replying. I pasted the openflow commands here. http://pastebin.com/q2NQLU1m Please let me know.

madhu22 ( 2014-11-19 09:27:06 -0800 )edit

@Anil- Wireshark is not showing the br-tun in the interface list..

madhu22 ( 2014-11-19 09:35:10 -0800 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-18 02:24:22 -0800

chandralekha gravatar image

I had issues in updating the topology of ovs switchs and connectivity between them when i was testing the odl using robotframework with simulated topology. At that time of testing i was using slow performance system. When i upgraded my controller PC to higher end system i was able to clearly see the topology in GUI spontaneously. Maybe you also have the similar issue. Try running controller in higher end systems

edit flag offensive delete publish link more

Comments

I am using high end system but my ovs-swicth s1 is not able to connect with controller. @Madhu which version of ODL you are using hydrogen or Helium? @Chandra :- In Helium , I think this issue is because of controller is not having any feature regarding openflowplugin. There should be some way to patch Openflowplugin with controller. Thanks Devesh

devverma ( 2014-11-18 04:10:40 -0800 )edit

I am using hydrogen release. I can see the openflow nodes from the VMs. But I don't see the connection between the br-tun and br-int. Can you please let me know what to look on the controller and compute?

madhu22 ( 2014-11-18 17:35:09 -0800 )edit
Login/Signup to Answer

Question Tools

Follow
2 followers

Stats

Asked: 2014-11-17 11:12:51 -0800

Seen: 1,122 times

Last updated: Nov 18 '14