Install plugin in Beryllium-SR1

asked 2016-05-12 21:30:21 -0700

vince gravatar image

updated 2016-05-12 21:31:13 -0700

Hi All: I am new in SDN project, and had a problem in installing plugin. I did run up with Beryllium, then run with command likes "feature:repo-add mvn: XXXXX", Afterward, i want to install it. Following an error msg like this.

#

opendaylight-user@root>feature:instal PLUGINNAME

Error executing command: Error resolving artifact org.opendaylight.yangtools:features-yangtools:xml:features:0.8.3-SNAPSHOT: Could not find artifact org.opendaylight.yangtools:features-yangtools:xml:features:0.8.3-SNAPSHOT in defaultlocal (file:/Users/ming/Documents/distribution-karaf-0.4.1-Beryllium-SR1/system/)

#

I have no idea with it. I have fill 0.8.3 as yangtool version in my pom.xml. and it compiled successfully. I wonder why this error happen when install the plugin. Any ideas or help would be appreciated.

PS: I have made several dependency version modified among pom files with my project. Because it was originally developed in Lithium. I wonder if it was the point to lead this error happened.

edit retag flag offensive close merge delete

Comments

If there has example about developing plugin in Beryllium would be great!

vince ( 2016-05-12 21:33:37 -0700 )edit

There is the hello world example in the developers guide of beryllium. You can also check if yangtools/0.8.3-SNAPSHOT is present in your /system/org/opendaylight/yangtools folder. As stated in another question, try compiling the integration distribution of beryllium and install your plugin there.

Lorunification ( 2016-05-13 00:10:05 -0700 )edit