Unable to start DLUX

asked 2016-04-21 16:18:04 -0700

anumercian gravatar image

After the update to the .m2/settings.xml file from http to https. After mvn clean install on the source ODL NIC project folder, I am unable to load DLUX using the URL from the browser because of the following error found on the logs:

2016-04-21 16:12:49,385 | ERROR | rint Extender: 3 | BlueprintContainerImpl | 15 - org.apache.aries.blueprint.core - 1.4.2 | Unable to start blueprint container for bundle org.opendaylight.dlux.common.topbar due to unresolved dependencies [(objectClass=org.osgi.service.http.HttpService), (objectClass=org.opendaylight.dlux.loader.DluxModuleLoader)] java.util.concurrent.TimeoutException at org.apache.aries.blueprint.container.BlueprintContainerImpl$1.run(BlueprintContainerImpl.java:336)[15:org.apache.aries.blueprint.core:1.4.2] at org.apache.aries.blueprint.utils.threading.impl.DiscardableRunnable.run(DiscardableRunnable.java:48)[15:org.apache.aries.blueprint.core:1.4.2] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.082-hpe] at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.082-hpe] at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)[:1.8.082-hpe] at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)[:1.8.082-hpe] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.082-hpe] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.082-hpe] at java.lang.Thread.run(Thread.java:745)[:1.8.0_82-hpe]

Can anyone please help with this?

edit retag flag offensive close merge delete