karaf add repository error

asked 2016-04-04 18:31:43 -0700

kimguji gravatar image

updated 2016-04-04 18:42:24 -0700

I installed stable lithium version of controller, dlux, and snmp4sdn.
After launch karaf of controller, I tried install feature dlux and snmp4sdn.
In order to install features, snmp4sdn repository should be added.
As shown in this link, https://wiki.opendaylight.org/view/SN... .

feature:repo-add mvn:org.opendaylight.snmp4sdn/y.y.y-SNAPSHOT/xml/features

(y.y.y is as the version number of the SNMP4SDN Plugin manually built. The version number: refer to snmp4sdn's source code, ~/snmp4sdn/snmp4sdn/pom.xml, find <artifactid>snmp4sdn</artifactid><version>y.y.y-SNAPSHOT</version>)

I checked myfolder/snmp4sdn/snmp4sdn/pom.xml, it was 0.2.4-Lithium-SR4.

However, when I added repository with this commands, it shows this error

opendaylight-user@root>feature:repo-add mvn:org.opendaylight.snmp4sdn/0.2.4-Lithium-SR4/xml/features Adding feature url mvn:org.opendaylight.snmp4sdn/0.2.4-Lithium-SR4/xml/features Error executing command: Error resolving artifact org.opendaylight.snmp4sdn:0.2.4-Lithium-SR4:features:xml: Could not find artifact org.opendaylight.snmp4sdn:0.2.4-Lithium-SR4:features:xml in central ( http://repo1.maven.org/maven2/ )

I already installed snmp4sdn in my server. I had file in my /.m2/repository
$ ls ~/.m2/repository/org/opendaylight/snmp4sdn/snmp4sdn/0.2.4-Lithium-SR4/
_remote.repositories snmp4sdn-0.2.4-Lithium-SR4.pom
snmp4sdn-0.2.4-Lithium-SR4.jar snmp4sdn-0.2.4-Lithium-SR4-sources.jar
snmp4sdn-0.2.4-Lithium-SR4-javadoc.jar

There are jar files, but no xml file. Is it a problem? I tried other snmp4sdn directories, but failed..
I also moved jar files to system/org/opendaylight/snmp4sdn/ folders, but failed.
If anyone knows solution, please give me some comments.
Thanks in advance.

edit retag flag offensive close merge delete

Comments

I tried to use karaf.... However, it did not work smooth as I thought. Instead, I installed integration and snmp4sdn projects and modified code. This way, anyway... source modification worked well...

kimguji ( 2016-04-05 02:08:41 -0700 )edit