Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

curl: command not found

asked 2016-04-02 11:32:17 -0800

meet56 gravatar image

updated 2016-04-02 11:33:10 -0800

Also, I had installed curl in ubuntu 14.04. Still, I am getting error command not found: curl.What am I missing? Is there any karaf feature to be installed for that? I am using opendaylight beryllium

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2016-04-02 18:55:37 -0800

harsha gravatar image

It is no way related to ODL. Try to install it properly.

edit flag offensive delete publish link more
0

answered 2016-04-02 19:49:31 -0800

azhark gravatar image

sudo apt-get update sudo apt-get upgrade sudo apt-get install curl

edit flag offensive delete publish link more
0

answered 2016-04-02 20:41:01 -0800

meet56 gravatar image

Thanks harsha and azhark for replying. Actually, I am trying to block the tcp datagrams using "curl" in controller (opendaylight-user@root>curl -a -H.........) as given in the link http://www.frank-durr.de/?p=68 . After that, I am getting "command not found: curl" I am sure that curl is installed properly. i run the command (whereis curl) to check. Please have a look into the link and help if you can. Thanks

edit flag offensive delete publish link more

Comments

I guess you are using OpenDaylight terminal to push flows. Push flows from another terminal where ODL is not running. Hope this helps!

harsha ( 2016-04-02 21:36:00 -0800 )edit

Exactly. cURL should not be used in ODL panel. Use it in terminal window of Ubuntu.

azhark ( 2016-04-08 09:38:47 -0800 )edit
Login/Signup to Answer

Stats

Asked: 2016-04-02 11:32:17 -0800

Seen: 1,634 times

Last updated: Apr 02 '16