Ask Your Question
0

ODL takes quite a long time to start

asked 2014-11-12 04:36:08 -0700

scurtis gravatar image

I'm running ODL from the latest git version but it regularly takes quite a long time to load:

Setting maximum memory to 1G.
"C:\Program Files\Java\jdk1.8.0_25\bin\java.exe" -Dopendaylight.controller  -Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8000  -Xmx1G -Djava.io.tmpdir="C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\work\tmp" -Djava.awt.headless=true -Dosgi.install.area=C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\ -Dosgi.configuration.area="C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\configuration" -Dosgi.frameworkClassPath="file:\C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\lib\org.eclipse.osgi-3.8.1.v20120830-144521.jar,file:\C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\lib\org.eclipse.virgo.kernel.equinox.extensions-3.6.0.RELEASE.jar,file:\C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\lib\org.eclipse.equinox.launcher-1.3.0.v20120522-1813.jar" -Dosgi.framework="file:\C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\lib\org.eclipse.osgi-3.8.1.v20120830-144521.jar" -classpath "C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\lib\org.eclipse.osgi-3.8.1.v20120830-144521.jar;C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\lib\org.eclipse.virgo.kernel.equinox.extensions-3.6.0.RELEASE.jar;C:\Users\700608667\Projects\SITB\ODL\controller\opendaylight\distribution\opendaylight\target\distribution.opendaylight-osgipackage\opendaylight\lib\org.eclipse.equinox.launcher-1.3.0.v20120522-1813.jar" org.eclipse.equinox.launcher.Main -console -consoleLog
Listening for transport dt_socket at address: 8000
!SESSION 2014-11-12 12:17:01.574 -----------------------------------------------

eclipse.buildId=unknown
java.version=1.8.0_25
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments:  -console -consoleLog

!ENTRY org.eclipse.osgi 4 0 2014-11-12 12:17:03.729
!MESSAGE Bundle reference:file:../lib/logging.bridge-0.5.0-SNAPSHOT@1:start not found.
2014-11-12 12:21:09.155 GMT [Start Level Event Dispatcher] INFO  o.a.sshd.common.util.SecurityUtils - Trying to register BouncyCastle as a JCE provider
2014-11-12 12:21:09.893 GMT [Start Level Event Dispatcher] INFO  o.a.sshd.common.util.SecurityUtils - Registration succeeded
2014-11-12 12:21:10.664 GMT [ControllerI/O Thread] INFO  o.o.c.p.o.c.internal.ControllerIO - Controller is now listening on any:6633
2014-11-12 12:21:35.546 GMT [Start Level Event Dispatcher] INFO  o.o.c.c.s.internal.ClusterManager - I'm a GossipRouter will listen on port 12001

You can see that this takes nearly seven minutes to startup. Is this normal or is there something that can be done to speed this up? Something to do with the "logging.bridge-0.5.0-SNAPSHOT@1:start not found" message perhaps?

Note I have seen this consistently happen across multiple developer machines and operating systems.

Thanks in advance

edit retag flag offensive close merge delete

Comments

Are you experiencing slow start with debug disabled?

Tony Tkacik ( 2014-11-14 06:40:24 -0700 )edit

Yes I see similar timings whether or not debug is enabled. I'm assuming it's something to do with the "!MESSAGE Bundle reference:file:../lib/logging.bridge-0.5.0-SNAPSHOT@1:start not found." statement and the OSGI container is waiting on a timeout firing before continuing.

scurtis ( 2014-11-17 05:56:03 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-12 09:20:34 -0700

anu.nair gravatar image

You can go to configuration/initial and remove some applications if not required. eg 03-toaster.xml..

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2014-11-12 04:36:08 -0700

Seen: 395 times

Last updated: Dec 12 '14