Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

How to use openday light with openflow 1.0?

asked 2016-02-20 14:54:20 -0800

I see it runs Openflow 1.3 by default but my project requires me to use 1.0. I am not sure how to do that

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-02-21 20:10:24 -0800

saisujithreddy gravatar image

When Running mininet - You can specify which protocol to use.

sudo mn --controller=remote,ip=<controller-ip> --switch=ovsk,protocols=OpenFlow13 --topo=linear,1

sudo mn --controller=remote,ip=<controller-ip> --switch=ovsk,protocols=OpenFlow10 --topo=linear,1

edit flag offensive delete publish link more

Comments

I am not using mininet.. Like what if I have a physical switch which only supports Open flow 1.0 and then fails to interact due a handshake error. Controller is sending switch Hello in OF 1.3 whereas switch(es) are trying to send using OF 1.0

deepanshululla ( 2016-02-21 21:07:53 -0800 )edit
0

answered 2016-02-22 12:30:40 -0800

jamoluhrsen gravatar image

the openflowplugin features in OpenDaylight will support both openflow 1.0 and 1.3

if you are having trouble connecting your 1.0 switch, then some debugging is needed. You can check logs on the switch (not sure those details) and you can check the karaf.log on the system running OpenDaylight. If there are no clues there, you can try a packet capture to see if there is possibly something wrong with the initial connection setup.

edit flag offensive delete publish link more

Comments

The packet capture showed Opendaylight sending Openflow 1.3 hello packets and the device sending openflow 1.0 hello packets

deepanshululla ( 2016-02-26 16:08:05 -0800 )edit
Login/Signup to Answer

Stats

Asked: 2016-02-20 14:54:20 -0800

Seen: 32 times

Last updated: Feb 22 '16