Ask Your Question
1

OVS patch does not add nsh header

asked 2016-02-04 06:59:16 -0700

AntonySilvester gravatar image

We are trying to use pritesh OVS patch for adding NSH header, i have added a flow rule like below in table 0

sudo ovs-ofctl add-flow br-int idletimeout=180,priority=33000,inport=6,actions=setnsi:255,setnsp:0x1,output:11

The flow rule hits, but it does not add the NSH header to the packet.

Please let me know is there anything i am missing or any configuration need to do in OVS.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-05-26 08:41:37 -0700

How have you determined that the NSH header hasnt been added to the packet?

What type of OVS port is the OpenFlow port 11? The encapsulation is performed by the port, so if its not a VXLAN-GPE port, then the packet wont get encapsulated.

Here is a sample SFF (Service Function Forwarder) configuration I use that should setup the port correctly. Notice the service-function-forwarder-ovs:ovs-options. The sfc-ovs feature uses the OVSDB southbound to configure the port.

{
  "service-function-forwarders": {
    "service-function-forwarder": [
      {
        "name": "sff1",
        "service-function-forwarder-ovs:ovs-bridge": {
            "bridge-name": "br-int"
        },
        "sff-data-plane-locator": [
          {
            "name": "veth0",
            "data-plane-locator":
            {
                "ip": "159.107.12.233",
                "port": 6633,
                "transport": "service-locator:vxlan-gpe"
            },
            "service-function-forwarder-ovs:ovs-options": {
                "nsp": "flow",
                "nshc4": "flow",
                "nshc3": "flow",
                "nshc2": "flow",
                "nshc1": "flow",
                "key": "flow",
                "dst-port": "6633",
                "nsi": "flow",
                "remote-ip": "flow"
            }
          }
        ],
        "service-function-dictionary": [
          {
            "name": "sf1",
            "sff-sf-data-plane-locator":
            {
                "sf-dpl-name": "sf1-dpl",
                "sff-dpl-name": "veth0"
            }
          }
        ]
      }
    ]
  }
}
edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-02-04 06:59:16 -0700

Seen: 151 times

Last updated: May 26 '16