Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode


odl-ovsdb-openstack feature Karaf

asked 2016-01-14 04:54:07 -0700

Gabs90 gravatar image

updated 2016-01-14 04:55:52 -0700

Hi everyone,

I'm trying to deploy a opendaylight+openstack integration by creating an ansible playbook, So far I have done the entire integration, but to doing so I have to manually install the feature odl-ovsdb-openstack in the karaf shell, and I am looking for the way to do it automatically once opendaylight is started,so I have the following question:

If I add the odl-ovsdb-openstackfeature in the org.karaf.features.cfg in the featuresBoot section it will install the feature that I want automatically? or do I need to specify the repository in the featuresRepositories section?, and if I have to do it, can anyone tell me where I can find the repositories for that feature?

Thank you all!

Best Regards


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-01-14 08:15:02 -0700

The upstream OpenDaylight Ansible role and Puppet module do this, so I suggest using them as examples (or just consuming ansible-opendaylight, if that makes sense in your usecase).

It seems like you have the basics of how to do this correct, there's not an obvious step you're missing. You can add features you want installed at Karaf boot to featuresBoot, as shown here for Ansible and here for Puppet.

The featuresRepositories section just needs to match the ODL version you're installing, you shouldn't need to mess with it. Specifically, it needs this repo to find ODL features (for the correct ODL version). Else, running feature:list at the Karaf shell will show no ODL-specific features.

edit flag offensive delete publish link more


Thanks!! I think that my problem was that the feature repo was not the same version than the opendaylight repo file, I have the SR3-lithium version and the default repo was from an older version, i changed it to

and it worked!! Thank you so much for your help!!

Gabs90 ( 2016-01-14 09:04:33 -0700 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2016-01-14 04:54:07 -0700

Seen: 212 times

Last updated: Jan 14 '16