can't connect to JUNOS with netconf

asked 2016-01-12 19:19:05 -0800

keven gravatar image

updated 2016-01-12 19:24:51 -0800

hi , i used 0.3.4 release and 0.4 snapshot version for test netconf on junos device , ODL can't connect to netconf server , and get error message by REST :

http://192.168.1.100:8181/restconf/op...

<topology>

<topology-id>topology-netconf</topology-id>

<node>

<node-id>junos</node-id>

<connection-status>unable-to-connect</connection-status>

<connected-message>RemoteDevice{junos}: No more sources for schema context</connected-message>

</node>

</topology>

following text in 99-netconf-connector.xml :

<snapshot>

<configuration>

<data xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">

  <modules xmlns="urn:opendaylight:params:xml:ns:yang:controller:config">

    <!-- Loopback connection to netconf server in controller using netconf-connector -->

    <modules>

    <module>

      <type xmlns:prefix="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">prefix:sal-netconf-connector</type>

      <name>junos</name>

      <address xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">192.168.1.200</address>

      <port xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">830</port>

      <username xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">root</username>

      <password xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">root</password>

      <tcp-only xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">false</tcp-only>

      <reconnect-on-changed-schema xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">true</reconnect-on-changed-schema>

      <event-executor xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">

        <type xmlns:prefix="urn:opendaylight:params:xml:ns:yang:controller:netty">prefix:netty-event-executor</type>

        <name>global-event-executor</name>

      </event-executor>

      <binding-registry xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">

        <type xmlns:prefix="urn:opendaylight:params:xml:ns:yang:controller:md:sal:binding">prefix:binding-broker-osgi-registry</type>

        <name>binding-osgi-broker</name>

      </binding-registry>

      <dom-registry xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">

        <type xmlns:prefix="urn:opendaylight:params:xml:ns:yang:controller:md:sal:dom">prefix:dom-broker-osgi-registry</type>

        <name>dom-broker</name>

      </dom-registry>

      <client-dispatcher xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">

        <type xmlns:prefix="urn:opendaylight:params:xml:ns:yang:controller:config:netconf">prefix:netconf-client-dispatcher</type>

        <name>global-netconf-dispatcher</name>

      </client-dispatcher>

      <processing-executor xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">

        <type xmlns:prefix="urn:opendaylight:params:xml:ns:yang:controller:threadpool">prefix:threadpool</type>

        <name>global-netconf-processing-executor</name>

      </processing-executor>

      <keepalive-executor xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">

        <type xmlns:prefix="urn:opendaylight:params:xml:ns:yang:controller:threadpool">prefix:scheduled-threadpool</type>

        <name>global-netconf-ssh-scheduled-executor</name>

      </keepalive-executor>

    </module>

    </modules>

</data>

</configuration>

<required-capabilities>

  <capability>urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf?module=odl-sal-netconf-connector-cfg&revision=2015-08-03</capability>

</required-capabilities>

</snapshot>

edit retag flag offensive close merge delete