Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

Error : Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))"

you don't have correct version of java set as $JAVA_HOME. If you try to echo $JAVA_HOME at terminal then you will see the version of java you are using.

If the $JAVA_HOME comes empty that means it is not set. set the java home using following command (ensure the path before setting it).

linux :

export JAVA_HOME=/usr/lib/jvm/java-1.7.0-openjdk-amd64

OSX:

export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home

to make it permanent put above line in your ~/.bashrc file. Now you can run the ODL.