Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

click to hide/show revision 1
initial version

I believe I've found the reason as to why my current script does not work. We were working using Helium-SR3. At the time that Helium was forked off, there was a bug involving resubmit. After the fork, there were several bugfixes, one of which included adding resubmit properly so that it could be invoked through the REST interface. Therefore, the error is real in that resubmit simply has not yet been added in the version that I'm working with, even if I specify the proper location. We're going to update to SR4 and I'll post an answer if it works properly with the relevant fixes.

UPDATE: We never did get the XML to work, but the JSON given above does work in Lithium, not sure if it works in Helium. Since it is valid JSON, I'll accept the answer that was given, though I'd like a working XML version too....

I believe I've found the reason as to why my current script does not work. We were working using Helium-SR3. At the time that Helium was forked off, there was a bug involving resubmit. After the fork, there were several bugfixes, one of which included adding resubmit properly so that it could be invoked through the REST interface. Therefore, the error is real in that resubmit simply has not yet been added in the version that I'm working with, even if I specify the proper location. We're going to update to SR4 and I'll post an answer if it works properly with the relevant fixes.

UPDATE: We never did get the XML to work, but the JSON given above does work in Lithium, not sure if it works in Helium. Since it is valid JSON, I'll accept the answer that was given, though I'd like a working XML version too....too....As a result, I'm leaving the title as [Unresolved] due to the answer given not having been tested by us in Helium, and never having gotten a working XML version. I will change the title to Resolved if a working XML equivalent is provided.

I believe I've found the reason as to why my current script does not work. We were working using Helium-SR3. At the time that Helium was forked off, there was a bug involving resubmit. After the fork, there were several bugfixes, one of which included adding resubmit properly so that it could be invoked through the REST interface. Therefore, the error is real in that resubmit simply has not yet been added in the version that I'm working with, even if I specify the proper location. We're going to update to SR4 and I'll post an answer if it works properly with the relevant fixes.