Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

click to hide/show revision 1
initial version
  1. The port 8080 is opened (IPtables and selinux disabled) [root@opendaylight ~]# lsof -i -nP | grep 8080 java 19922 root 98u IPv6 138372 0t0 TCP *:8080 (LISTEN)

  2. I used curl trigger a HTTP request [root@openstack01 ~]# curl -u admin:admin http://<odl-ip>:8080/controller/nb/v2/neutron/networks { "networks" : [ ] }

another test is: curl -u admin:admin http://10.9.99.44:8080/controller/nb/v2/neutron <html><head><title>Apache Tomcat/7.0.53 - Error report</title><style></style> </head><body>

HTTP Status 404 - Not Found


type Status report

message Not Found

description The requested resource is not available.


Apache Tomcat/7.0.53

</body></html>

  1. I am using Helium ODL and still get the same error.

ERROR neutron.plugins.ml2.managers [req-b0414c73-f1d5-454a-81ab-252873531307 None] Mechanism driver 'opendaylight' failed in createnetworkpostcommit

I am running neutron server on my control node. I put the neutron server in the debug mode and still didn't find any clue of why I am getting the upper error.